Code.org - High latency and error rates on studio.code.org – Incident details

All systems operational

High latency and error rates on studio.code.org

Resolved
Partial outage 50 %
Started about 14 hours agoLasted about 9 hours

Affected

HourOfCode.com

Operational from 12:25 PM to 2:12 PM, Partial outage from 2:12 PM to 7:09 PM, Operational from 7:09 PM to 9:54 PM

Studio.Code.org

Degraded performance from 12:25 PM to 2:12 PM, Partial outage from 2:12 PM to 7:09 PM, Operational from 7:09 PM to 9:54 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Upstream AWS Services have mostly been restored, but our ability to scale suitably with traffic is no longer effected. We will continue monitoring for issues, and invest in extra resilience through the coming days to avoid a repeat incident.

  • Update
    Update

    The upstream incident at AWS is starting to get resolved, and we have been able to scale up our systems. At this time error rates should be back to near-zero, and the site should be fully usable. We will continue to monitor for new issues and update this when the upstream incident is fully resolved.

  • Monitoring
    Monitoring

    Due to an availability incident with Amazon Web Services (AWS), we are currently unable to scale up to meet the demand of Monday morning traffic. Performance will be severely degraded until resolved. We are seeing signs of improvement from the AWS side, and are continuing to monitor and work to ensure speedy recovery.

  • Update
    Update

    Due to an availability incident with Amazon Web Services (AWS), we are currently unable to scale up to meet the demand of Monday morning traffic. Performance will be severely degraded until resolved. We are monitoring the issue and exploring options to mitigate the impact. We will continue to update this page.

  • Identified
    Identified

    Due to an availability issue with Amazon Web Services, we are still seeing elevated error rates and latency.